• +91-833 690 7306
  • +91-833 690 7305
  • info@inetworkexperts.com

How Static NAT works and Configuration?

Network Address Translation (NAT) is designed for IP address conservation. It enables private IP networks that use unregistered IP addresses to connect to the Internet. NAT operates on a router, usually connecting two networks together, and translates the private (not globally unique) addresses in the internal network into legal addresses, before packets are forwarded to another network.

Also NAT can be configured in such scenario where a company has merged with another company, both the companies network are using same address space then NAT could the solution. Here NAT will help you not to overlap IP address between two networks.

NAT can be configured in two different ways,

a) Static NAT
b) Dynamic NAT

There is one more mechanism available which is PAT (Port Address Translation).

Configuration of Static NAT, which will perform 1:1 IP mapping between Private IP and Public IP or anything. This should be configured manually at the NAT border router. In our case R1 is NAT border router as R1 is the point of contact between Private Network and Public Network (Internet).

Configuration:

R1:

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 172.16.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#interface fastEthernet 0/1
R1(config-if)#ip address 59.16.12.1 255.255.255.0
R1(config-if)#no shutdown

!!! Default Static Route pointing to Internet Router to reach inside network to outside.

R1(config)#ip route 0.0.0.0 0.0.0.0 59.16.12.2

!!! Static NAT Configuration

R1(config)#ip nat inside source static 172.16.10.5 201.1.1.1

R1(config)#ip nat inside source static 172.16.10.10 201.1.1.2

!!! Defining Inside Network and Outside Network

R1(config)#interface fastEthernet 0/1
R1(config-if)#ip nat outside

R1(config-if)#interface fastEthernet 0/0
R1(config-if)#ip nat inside

R2:        <<<This is Service Provider Router>>>

R2(config)#interface fastEthernet 0/1
R2(config-if)#ip address 59.16.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 59.16.20.2 255.255.255.0
R2(config-if)#no shutdown

!!! Use Static route to reach Inside Global IP address from Service Provider Router

R2(config)#ip route 201.1.1.0 255.255.255.0 59.16.12.1

  • Share This:

Leave a Reply

Your email address will not be published. Required fields are marked *